Commit b33fcf78 authored by Alan Garcia's avatar Alan Garcia

Bug de upgrade check

parent 80e96bc4
......@@ -535,14 +535,14 @@ install/upgrades/0.9.5.sql -text
install/upgrades/0.9.6.sql -text
install/upgrades/0.9.7.sql -text
install/upgrades/0.9.9.sql -text
install/upgrades/1.0.0.sql -text
install/upgrades/1.0.1.php -text
install/upgrades/1.0.3.sql -text
install/upgrades/1.0.4.sh -text
install/upgrades/1.0.sql -text
install/upgrades/1.1.php -text
install/upgrades/1.1.sh -text
install/upgrades/3.0.sh -text
install/upgrades/3.0.sql -text
install/upgrades/1.1.0.php -text
install/upgrades/1.1.0.sh -text
install/upgrades/3.0.0.sh -text
install/upgrades/3.0.0.sql -text
install/upgrades/README -text
lang/.svnignore -text
lang/README -text
......
......@@ -33,8 +33,7 @@ fi
# the upgrade script we are considering
extensions="*.sql *.sh *.php"
cd /usr/share/alternc/install/upgrades
for file in $extensions
do
for file in $( ls $extensions | sort -n ) ; do
if [ -r $file ]; then
# the version in the filename
upvers=`strip_ext $file`
......@@ -54,6 +53,9 @@ do
sh)
sh $file || true
;;
*)
# Do nothing
;;
esac
fi
fi
......
Fonctionnement des scripts de mise-à-jour d'AlternC
===================================================
/!\ ATTENTION /!\
Votre script DOIT etre numéroté sur trois chiffres, pas plus, pas moins.
Donc :
1.0.1.sql -> OK
1.0.2.5.sql -> PAS OK
1.0.sql -> PAS OK
Sinon, ca sera dans n'importe quel ordre.
Il a été décidé que des mises-à-jour pourront être "accrochées" à
certaines versions en les mettant dans le dossier upgrades. Lors de
l'installation d'un paquet, un script (upggrade_check.sh) examine ce
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment