Commit e482842c authored by Camille Lafitte's avatar Camille Lafitte

Compatibilit\303\251 Lenny (suite)

 * complete [2472]
  * Alternc slave n'avait pas le patch concernant proftpd
 * close #1197
  * il ne faut plus mettre '''<?php ?>''' pour l'inclusion phpmyadmin, on n\303\251ttoie au passage les anciennes installations
parent e1377289
......@@ -171,8 +171,14 @@ EOF
echo "config phpmyadmin"
include_str='include("/etc/alternc/phpmyadmin.inc.php")'
pma_config=/etc/phpmyadmin/config.inc.php
# Mise à jour sur une configuration existante
# recherche la chaine include_str (avec les / echappées) et supprime les <?php ?>
sed 's/<?php \('"${include_str//\//\\/}"'\) ?>/\1;/g' $pma_config > $pma_config'_2'
mv $pma_config'_2' $pma_config
# Sur une configuration vierge, inclure la configuration alternc
if ! grep -e "$include_str" $pma_config > /dev/null 2>&1; then
echo "<?php $include_str ?>" >> $pma_config
echo "$include_str;" >> $pma_config
fi
# Add access to the management panel
......
......@@ -29,7 +29,7 @@ Homepage: http://www.alternc.org/
Package: alternc-slave
Architecture: all
Pre-depends: debconf (>= 0.5.00) | debconf-2.0
Depends: debianutils (>= 1.13.1), apache2 | apache, libapache2-mod-php5 | libapache-mod-php5 | libapache2-mod-php4 | libapache-mod-php4, courier-ssl, courier-imap-ssl, courier-pop-ssl, php5-mysql | php4-mysql, phpmyadmin, postfix, proftpd-mysql, squirrelmail, postfix-tls, bind9, wget, rsync, quota, courier-authmysql | courier-authlib-mysql, ca-certificates, locales, perl-suid, perl, postfix-mysql, wwwconfig-common, sasl2-bin, libsasl2-modules, php5-cli | php4-cli, lockfile-progs (>= 0.1.9), gettext (>= 0.10.40-5), pdksh (>= 5.2.14-6), adduser, mysql-client, postgrey, scponly
Depends: debianutils (>= 1.13.1), apache2 | apache, libapache2-mod-php5 | libapache-mod-php5 | libapache2-mod-php4 | libapache-mod-php4, courier-ssl, courier-imap-ssl, courier-pop-ssl, php5-mysql | php4-mysql, phpmyadmin, postfix, proftpd-mod-mysql | proftpd-mysql, squirrelmail, postfix-tls, bind9, wget, rsync, quota, courier-authmysql | courier-authlib-mysql, ca-certificates, locales, perl-suid, perl, postfix-mysql, wwwconfig-common, sasl2-bin, libsasl2-modules, php5-cli | php4-cli, lockfile-progs (>= 0.1.9), gettext (>= 0.10.40-5), pdksh (>= 5.2.14-6), adduser, mysql-client, postgrey, scponly
Recommends: apache2 | libapache-mod-gzip, apache2 | apache-ssl
Conflicts: alternc-admintools, alternc-awstats (<= 0.3.2), alternc-webalizer (<= 0.9.4), alternc
Provides: alternc
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment