Commit 10dd07b0 authored by Benjamin Sonntag's avatar Benjamin Sonntag

DEBUG ON on postinst/preinst/config ... scripts + depends on BASH for them

parent 5d9d520d
#! /bin/sh
#! /bin/bash -x
set -e
......@@ -16,7 +16,7 @@ if [ "$RET" = "false" ]; then
# reset the welcomeconfirm flag if user refuses so it gets asked again next time
db_reset alternc/welcomeconfirm || true
db_fset alternc/welcomeconfirm "seen" "false" || true
exit 1
exit 3
fi
# default values for local.sh
......@@ -140,7 +140,7 @@ check_mysql(){
db_go
db_get alternc/remote_mysql_error || true
if [ "$RET" = "false" ]; then
exit 1
exit 4
fi
fi
done
......@@ -193,7 +193,7 @@ if [ -z "$ACL" ]; then
db_title AlternC
db_reset alternc/acluninstalled || true
db_fset alternc/acluninstalled "seen" "false" || true
exit 1
exit 2
fi
quota_activation=$(quotaon -pa 2>/dev/null |grep '^group.*on$' | /usr/bin/awk '$4 ~ /^\'$MOUNT_POINT'$/ {print $4}')
......
#!/bin/sh
#!/bin/bash -x
set -e
......
#! /bin/sh
#! /bin/bash -x
set -e
......
#!/bin/sh
#!/bin/bash -x
set -e
......
#!/bin/sh -e
#!/bin/bash -e -x
# Debian alternc prerm
# Benjamin Sonntag <benjamin@alternc.org>
......
......@@ -9,8 +9,8 @@ Standards-Version: 3.9.1
Package: alternc
Architecture: all
Pre-depends: debconf (>= 0.5.00) | debconf-2.0
Depends: debianutils (>= 1.13.1), apache2-mpm-itk, libapache2-mod-php5, php5-mysql, phpmyadmin, postfix, proftpd-mod-mysql, proftpd-basic, bind9, wget, rsync, ca-certificates, locales, perl-suid | perl, postfix-mysql, wwwconfig-common, sasl2-bin, libsasl2-modules, php5-cli, lockfile-progs (>= 0.1.9), gettext (>= 0.10.40-5), sudo, adduser, mysql-client, dnsutils, bash (>= 4), acl, dovecot-imapd (>= 1:1.2.15), dovecot-pop3d (>= 1:1.2.15), vlogger, mailx
Pre-depends: debconf (>= 0.5.00) | debconf-2.0, bash (>= 4)
Depends: debianutils (>= 1.13.1), apache2-mpm-itk, libapache2-mod-php5, php5-mysql, phpmyadmin, postfix, proftpd-mod-mysql, proftpd-basic, bind9, wget, rsync, ca-certificates, locales, perl-suid | perl, postfix-mysql, wwwconfig-common, sasl2-bin, libsasl2-modules, php5-cli, lockfile-progs (>= 0.1.9), gettext (>= 0.10.40-5), sudo, adduser, mysql-client, dnsutils, acl, dovecot-imapd (>= 1:1.2.15), dovecot-pop3d (>= 1:1.2.15), vlogger, mailx
Recommends: mysql-server(>= 5.0), ntp, quota
Conflicts: alternc-admintools, alternc-awstats (< 1.0), alternc-webalizer (<= 0.9.4), alternc-mailman (< 2.0)
Provides: alternc-admintools
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment