Commit b3288c55 authored by chris's avatar chris

Fix package deps and content display

parent ebeabbcc
......@@ -3,3 +3,4 @@
*~
env
media
local_settings.py
......@@ -6,7 +6,8 @@ Build-Depends: debhelper (>= 9),
dh-python,
python-all (>= 2.6.6-3~),
python-sphinx,
python-django (>= 1.6)
python-sorl-thumbnail,
python-django
Homepage: https://flyers.domainepublic.net
Vcs-Git: http://git.domainepublic.net/git/flyers.git/
Vcs-Browser: http://git.domainepublic.net/?p=flyers.git
......@@ -14,7 +15,7 @@ Vcs-Browser: http://git.domainepublic.net/?p=flyers.git
Package: python-flyers
Section: python
Architecture: all
Depends: ${python:Depends},
Depends: python-all (>= 2.6.6-3~),
${misc:Depends}
Recommends: python-ldap
Description: Python libraries of Flyers
......
......@@ -8,4 +8,5 @@ export DH_VERBOSE=1
dh $@ --with python2,sphinxdoc --buildsystem=pybuild
override_dh_auto_test:
./manage.py test flyers flyers.content flyers.general
#./manage.py test flyers flyers.content flyers.general
echo 'django-translation not in debian repo yet'
# -*- coding: utf-8 -*
from flyers.settings import *
import os
......
......@@ -4,7 +4,7 @@
{% block title %} - {{ object.title }}{% endblock %}
{% block content %}
{% if object.text or object.page_set|length %}
{% if object.text or object.page_set.all|length > 0 %}
<div class="pagewrap">
<div class="page">
<div class="pagelinks">
......
......@@ -106,6 +106,12 @@ LANGUAGES = (
('ca', 'Català'),
)
MODELTRANSLATION_TRANSLATION_REGISTRY = ('flyer.translation',)
SITE_MULTILINGUAL = True
SITE_MULTILINGUAL = False
if SITE_MULTILINGUAL:
INSTALLED_APPS += ('modeltranslation',)
try:
from local_settings import *
except ImportError, e:
pass
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment